解决 You are using pip version 8.1.2, however version 23.2.1 is available 报错。

在安装 docker-compose的时候需要先安装 或升级pip 使用命令  1、 pip install --upgrade pip   运行后会报错 如图。 2、原因是 yum install python-pip 时,CentOS7 默认安装的python版...

在安装 docker-compose的时候需要先安装 或升级pip

使用命令 

1、 pip install --upgrade pip   运行后会报错 如图。

attachments-2023-10-Y0lulJmA6528e58a92f0c.png


2、原因是 yum install python-pip 时,CentOS7 默认安装的python版本是2.7。它不支持更新到最新版本


解决办法:

安装python3的pip  ,使用以下命令

yum install python3-pip


使用pip3 指令升级pip
pip3 install --upgrade pip

attachments-2023-10-NWD77rB76528e71e86de1.png

然后后面安装 使用pip3 install 指令 代替 pip
  • 发表于 2023-10-13 14:45
  • 阅读 ( 747 )
  • 分类:服务器

你可能感兴趣的文章

相关问题

0 条评论

请先 登录 后评论
东北大表哥
东北大表哥

自由职业

161 篇文章

作家榜 »

  1. 东北大表哥 161 文章
  2. 小鹄 1 文章
  3. 阿天 0 文章
  4. 新百胜在线 0 文章
  5. 刘明明 0 文章
  6. 个的德3 0 文章
  7. 铂天先生 0 文章
  8. 王达 0 文章